Dynamics Slowness

Incident Report for Farber Group

Update

We’re continuing to monitor the situation. At this time, there are no new developments to report. Our team remains engaged and will provide further updates as needed.
Posted Dec 22, 2025 - 17:28 EST

Investigating

We are currently investigating an issue with Dynamics slowness. The issue has been escalated to Microsoft Engineers, updates will be provided as we get them.
Posted Dec 22, 2025 - 13:43 EST
This incident affects: Line Of Business (LOB) Applications (Dynamics CRM).