FileAssure Outage

Incident Report for Farber Group

Resolved

This incident has been resolved.
Posted Dec 12, 2025 - 09:33 EST

Investigating

We are currently investigating an issue preventing users to access FileAssure.
Posted Dec 12, 2025 - 09:15 EST
This incident affected: Line Of Business (LOB) Applications (FileAssure).