Dynamics SMS - Degraded performance

Incident Report for Farber Group

Resolved

This incident has been resolved.
Posted Jun 16, 2026 - 09:56 EDT

Investigating

We are currently investigating an issue involving Dynamics SMS
Posted May 19, 2026 - 14:10 EDT
This incident affected: Line Of Business (LOB) Applications (Dynamics CRM).