Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 22, 2026 - 12:30 EDT
Scheduled
The print server infrastructure supporting the North York 1 (Sheppard) office will be undergoing scheduled maintenance. During this maintenance window, users in the North York 1 (Sheppard) office may experience minimal brief interruptions when printing, connecting to printers, or retrieving printer status information.
This maintenance does not affect remote users or printers located outside of the North York 1 office. The maintenance does not impact scanning services.
No service-impacting changes are expected. If any interruption occurs, downtime is not expected to exceed 5 minutes. Print services will automatically resume once the maintenance process is completed.
Posted Jun 22, 2026 - 11:55 EDT
This scheduled maintenance affected: Printing and Scanning (PaperCut Print Management, Printing).