Dynamics 365 - Degraded performance for CP Inquiries forms

Incident Report for Farber Group

Resolved

This incident has been resolved.
Posted Jun 16, 2026 - 09:57 EDT

Investigating

We are currently investigating an issue with phone number fields in CP Inquiry forms
Posted Jun 08, 2026 - 14:48 EDT
This incident affected: Line Of Business (LOB) Applications (Dynamics CRM).