Microsoft 365 Services: Degraded Services

Incident Report for Farber Group

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 09:50 EST

Investigating

We are currently investigating this issue.
Posted Feb 04, 2026 - 11:56 EST
This incident affected: Office 365 (SharePoint, Office 365 App) and Audio and Video Collaboration (Microsoft Teams).